Opened 14 years ago

Closed 12 years ago

#6 closed defect (worksforme)

closing dbh with active statement handles

Reported by: Dominic Hargreaves Owned by: Dominic Hargreaves
Priority: minor Milestone:
Component: wiki-toolkit Version: svn
Keywords: hackfest2007-reviewed Cc:

Description

Most operations seem to result in

closing dbh with active statement handles

stderr output at the moment. Should be a trivial fix.

Change History (10)

comment:1 Changed 14 years ago by Dominic Hargreaves

Hmm, ignore this until I can track down where I saw those messages. They aren't popping up quite as often as I thought...

comment:2 Changed 14 years ago by nick

I've seen them a few times

Is there any way to get DBI to track where they were created? I've never managed to get this to show up in a simple case, so I've never figured out where the statement with data left was is.

comment:3 Changed 14 years ago by Dominic Hargreaves

Milestone: 0.70

comment:4 Changed 13 years ago by Dominic Hargreaves

(In [324]) Close some active statements (references #6)

comment:5 Changed 13 years ago by Dominic Hargreaves

Milestone: 0.70

I *think* this is due to problems upstream with DBD::SQLite. For example, see this: http://rt.cpan.org/Public/Bug/Display.html?id=17603

In any case... for the time being I will leave this bug open, but have removed the 0.70 milestone.

comment:6 Changed 13 years ago by Perigrin

Seems to happen in the following tests if that helps track it down:

t/017_delete_version..........................ok 30/78Asked to delete non existant version 2 of node 5 (Five Node) at /Users/perigrin/.cpan/build/Wiki-Toolkit-0.70/blib/lib/Wiki/Toolkit/Store/Database.pm line 1017. closing dbh with active statement handles

t/021_moderation..............................ok 72/164closing dbh with active statement handles t/021_moderation..............................ok 149/164closing dbh with active statement handles

comment:7 Changed 13 years ago by Dominic Hargreaves

Test this with DBD::SQLite 1.13 - above RT bug is closed.

comment:8 Changed 12 years ago by Dominic Hargreaves

Owner: changed from Dominic Hargreaves to Nobody

comment:9 Changed 12 years ago by Dominic Hargreaves

Keywords: hackfest2007-reviewed added
Owner: changed from Nobody to Dominic Hargreaves
Status: newassigned

comment:10 Changed 12 years ago by Dominic Hargreaves

Resolution: worksforme
Status: assignedclosed

Confirmed that these messages do not appear with DBD::Sqlite 1.13.

Note: See TracTickets for help on using tickets.